»查看更多分類股票軟件

MACD優化波段 通達信副圖指標 源碼 貼圖

發布時間:2019-06-19 09:57:00  點擊:

MACD優化波段 通達信副圖指標 源碼 貼圖

MACD優化波段 通達信副圖指標 源碼 貼圖


A:=CURRBARSCOUNT;
A1:=DAY!=REF(DAY,1);
A2:=BARSLAST(A1)+1;
A3:=MA(C,A2);
A4:=SUM(AMO,A2)/SUM(VOL,A2)/100;
A5:=IF(CAPITAL>0,A4,A3);
均價線:=IF(A<=CONST(A2),A5,DRAWNULL);
分鐘有效周期:=IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL))));
分時價:=TFILT(CLOSE,CURRBARSCOUNT,00,CURRBARSCOUNT,00);
分時判斷:=IF(分時價=DRAWNULL,1,IF(分鐘有效周期=DRAWNULL,DRAWNULL,1));
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
KX:=BARSSINCE(CLOSE);{←首次開盤價距金的天數}
HHN:=CONST(HHV(DIFF,KX));
HLN:=CONST(LLV(DEA,KX));
RC1:=CONST((HHN+HLN)/2);
SS:=((HHN-HLN)/200);
MACD底部:=(-100*SS+RC1)+-(-100*SS+RC1),COLOR669999;
MACD頂部:=(100*SS+RC1)+-(-100*SS+RC1),COLORFF0033;
MACD中軸:=0+-(-100*SS+RC1);
DIFF修正:=DIFF+-(-100*SS+RC1),COLOR008080;
DEA修正:=DEA+-(-100*SS+RC1),COLOR00FF00;
MACD修正:=2*(DIFF修正-DEA修正)+MACD中軸,COLOR0000BB,NODRAW;
MACD超跌:=CONST(LLV(MACD修正,KX));
MACD超跌線:=IF(MACD超跌<MACD底部,MACD超跌,MACD底部);
{----------------------利用MACD趨勢進行精確頂底判斷------------------------}
頂部:=MACD頂部+-MACD超跌線;
天際:=頂部*0.809;
中軸:=MACD中軸+-MACD超跌線;
海面:=頂部*0.191;
底部:=MACD底部;
{------------------------傳統KDJ指標結合MACD優化---------------------------}
RSVA:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*頂部;{采用21日月線優化}
K:SMA(RSVA,3,1),COLORFFFFFF,NODRAW;
D:SMA(K,3,1),COLOR00FFFF,NODRAW;
原J值參數:=3*K-2*D;{www.jjdkyu.tw}
JD:=IF(原J值參數<底部,底部,原J值參數);{J值底部鈍化處理}
J:IF(JD>頂部,頂部,JD),COLORFF00FF,NODRAW;{底部鈍化處理后再進行頂部鈍化處理}
{---------------------------MACD多空量能判斷-------------------------------}
MACD多頭:=DIFF修正+-MACD超跌線,COLOR339999;
空頭:=DEA修正+-MACD超跌線,COLOR00FF00;
量能柱:2*(MACD多頭-空頭)+中軸,COLOR0000BB,NODRAW;
超前DEA:=(EMA(MACD多頭,7));
超前MACD:=2*(MACD多頭-超前DEA)+中軸;
{-----------------------------------大盤動向-------------------------------}
VAR1大盤:=LLV(LOW,13);
VAR2大盤:=HHV(HIGH,13);
VAR3大盤:=(SMA((CLOSE-VAR1大盤)/(VAR2大盤-VAR1大盤)*頂部,5,1))-頂部/2;
VAR4大盤:=SMA((VAR2大盤-CLOSE)/(VAR2大盤-VAR1大盤)*頂部,5,1)-頂部/2;
大盤散戶:=IF(VAR4大盤<底部,底部,VAR4大盤),COLOR408000;
大盤主力:=IF(VAR3大盤<底部,底部,VAR3大盤),COLOR330088;
{---------------------------------密集成本突破-----------------------------}
最高獲利參數:=頂部/100;
VAR1C:=(COST(89)-COST(11))*最高獲利參數;
VAR2C:=(COST(99.9)-COST(1))*最高獲利參數;
單峰:=((1-VAR1C/VAR2C))*頂部;
低密:=((COST(90)-COST(60))/VAR2C)*頂部;
高密:=((COST(40)-COST(1))/VAR2C)*頂部;
贏利:= (SMA(WINNER(AMOUNT/VOL/99),2,1))*頂部;
活躍度:頂部-頂部/(1+EXPMA(HSL,21)),COLOR774455;{←CYF公眾追漲熱情指標}
70%成本集中度:=IF(VAR1C>頂部,頂部,VAR1C),COLORFFFFFF;
90%成本集中度:=IF(VAR2C>頂部,頂部,VAR2C),COLORFF0000;
套牢籌碼上升:=IF((單峰-贏利)>底部,(單峰-贏利),底部);
個股散戶:=IF(套牢籌碼上升>頂部,頂部,套牢籌碼上升),COLOR408000;
散戶:IF(個股散戶=DRAWNULL,DRAWNULL,個股散戶),COLOR408000;
獲利籌碼上升:=IF((贏利-單峰)>底部,(贏利-單峰),底部);
個股主力:=IF(獲利籌碼上升>頂部,頂部,獲利籌碼上升),COLOR330088;
主力:IF(個股主力=DRAWNULL,DRAWNULL,個股主力),COLOR330088;
{--------------------換手率,五日換手率輔助判斷個股活躍度-------------------}
換手:SUM(VOL,1)/CAPITAL*100,COLOR666666,NODRAW;
⑤日換:SUM(VOL,5)/CAPITAL*100,COLOR999999,NODRAW;
{----------------------密集成本突破指標籌碼峰畫線--------------------------}
金色背景修邊1:STICKLINE(C>0 AND CURRBARSCOUNT>=2,頂部,底部,3.05,0),COLOR003333;
金色背景修邊2:STICKLINE(C>0 AND CURRBARSCOUNT>=2,頂部,中軸,3.05,0),COLOR003333;
金色背景補充:DRAWBAND(頂部,RGB(51,51,0),中軸,RGB(51,51,0));
金色背景:DRAWBAND(頂部,RGB(51,51,0),底部,RGB(128,128,128));
追漲熱度峰紫色:DRAWBAND(活躍度,RGB(66,52,81),底部,RGB(204,0,0));
高密峰墨藍色:=DRAWBAND(高密,RGB(0,0,51),底部,RGB(0,0,255));
低密峰純藍色:=DRAWBAND(低密,RGB(0,0,102),底部,RGB(0,0,255));
90%成本峰:DRAWBAND(90%成本集中度,RGB(0,0,153),底部,RGB(0,0,153));
70%成本峰:DRAWBAND(70%成本集中度,RGB(0,128,0),底部,RGB(255,255,255));
散戶峰綠色:DRAWBAND(散戶,RGB(0,64,0),底部,RGB(204,0,0));
主力峰紅色:DRAWBAND(主力,RGB(102,26,51),底部,RGB(0,0,255));
MACD多空趨勢:DRAWBAND(MACD多頭,RGB(204,51,51),空頭,RGB(0,179,0));
MACD多頭重畫:=DRAWBAND(MACD多頭,RGB(153,153,51),MACD多頭,RGB(153,153,51));
MACD空頭重畫:=DRAWBAND(空頭,RGB(0,204,0),空頭,RGB(0,204,0));
{--------創幻論壇‘131488’會員提供的通達信■新寶塔線■-----原碼-----------}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

 
MACD優化波段 通達信副圖指標 源碼 貼圖
打開微信掃一掃,一鍵復制指標源碼,
輕松快捷粘貼至手機通達信APP中。
0

本站提示:股市有風險,入市請慎重,資料由股票下載網整理收集

找不到你要的公式?給我們建議

  1. 股票軟件
    股票分析軟件
    股票交易軟件
    股票行情軟件
    指標股票池
    手機炒股軟件
    書籍教程
    數據軟件
    工具補丁
    大智慧
    通達信
    飛狐
    東方財富通
    操盤手
    指南針
    分析家
    同花順
    錢龍
    證券之星
    券商股票軟件
    特色行情軟件
    迷你行情軟件
    金融界軟件
    美股外盤軟件
    大智慧股票池
    通達信股票池
    大智慧L2公式
    通達信公式
    飛狐公式
    同花順公式
    股票書藉
    視頻教程
    金融書籍
    其他書籍
    資訊評測軟件
    資金分析軟件
    數據接口軟件
    江恩波浪軟件
    數據下載軟件
    軟件數據投資
    選股軟件
    登錄補丁
    其他應用
    股軟教程
  2. 股票公式
    通達信公式
    大智慧公式
    飛狐公式
    同花順公式
    東方財富通公式
    金字塔指標公式
    文華指標公式
    MT4指標
    博易大師指標
    公式教程答疑
  3. 炒股知識
    短線技巧
    軟件公式
    炒股視頻
    股票入門
    股市實戰信息交流
    炒股技巧
    股票基礎知識
    技術分析
    炒股一招先
    基本面分析
    股票視頻教程
    股票買賣技巧
    k線圖分析
    胡立陽教你買股票
    短線炒股技巧
    天狼之眼
    波浪理論技術講解
    股市贏家楊百萬
    股票理論、T0纏論、知識
    經典指標、交易系統
    成交量能、籌碼分析
    買賣信號、技術分析
    挖坑、冼盤、吸籌、出貨
    均線戰法、黃金分割
    經典K線、趨勢形態
    牛股黑馬、王子理論
    漲停、周線、月線
    止盈、止損、支撐、壓力
    案例、波浪、口訣、選股
    分時、盤口、補倉、解套
  4. 技術指標
    DDX
    DDY
    DDZ
    MACD
    KDJ
    CCI
    OBV
    BOLL
    RSI
    VOL
    CR
    WR
高级二肖中特料